مهاجمان چطور کنترل سیستم را در دست می گیرند؟

مهاجمان چطور کنترل سیستم را در دست می گیرند؟

لباس نو: تعدادی آسیب پذیری دارای شدت بالا و متوسط در مرورگر فایرفاکس شناسایی شده که مهاجم با بهره برداری از تعدادی از این لطمه پذیری ها می تواند کنترل سیستم لطمه پذیر را در دست بگیرد.


به گزارش لباس نو به نقل از ایسنا، موزیلا برای رفع تعدادی لطمه پذیری در مرورگر فایرفاکسِ خود، بروزرسانی امنیتی منتشر کرد، این لطمه پذیری ها دارای شدت بالا و متوسط بوده و یک مهاجم با بهره برداری از تعدادی از این لطمه پذیری ها می تواند کنترل سیستم لطمه پذیر را در دست بگیرد. مرکز ماهر (مدیریت امداد و هماهنگی رخدادهای کامپیوتر ای) جزییات این لطمه پذیری ها را منتشر نموده است.
لطمه پذیری CVE-2022-22753 با شدت بالا، امکان ارتقاء سطح دسترسی به SYSTEM (بالاترین سطح دسترسی در سیستم های ویندوزی) را برای مهاجم بوسیله سرویس Maintenance در ویندوز فراهم می آورد. در حقیقت، یک نقص "زمان بررسی تا زمان استفاده" در سرویس Maintenance (Updater) وجود دارد که می تواند بمنظور اعطای دسترسیِ نوشتن در هر مسیر دلخواه، به کاربران، مورد سوءاستفاده قرارگیرد و این امر، دست یابی به سطح دسترسی SYSTEM را منجر خواهد شد.
این لطمه پذیری تنها مرورگر فایرفاکس در ویندوز را تحت تأثیر قرار می دهد و سایر سیستم عامل ها تحت تأثیر این لطمه پذیری قرار ندارند.
لطمه پذیری CVE-2022-22754 با شدت بالا، امکان دور زدن پروسه تأیید مجوز دسترسی را در هنگام به روزرسانی، برای افزونه ها فراهم می آورد.
لطمه پذیری CVE-2022-22764 با شدت بالا، اشکالات ایمنی حافظه را در بعضی از نسخه های پیشین فایرفاکس سبب می شود. توسعه دهندگان و اعضای انجمن موزیلا، Paul Adenot و تیم Mozilla Fuzzing، نقص های ایمنی حافظه را در Firefox 96 و Firefox ESR 91.5 گزارش کرده اند.
لطمه پذیری CVE-2022-22755 با شدت متوسط، سبب می شود که XSL امکان اجرای اسکریپت را بعد از بسته شدن برگه ی مرورگر (tab) فراهم آورد.
لطمه پذیری CVE-2022-22756 با شدت متوسط، سبب می شود که کشیدن و رها کردن یک تصویر، سبب تبدیل شدن آن به فایل اجرائی شود.
لطمه پذیری CVE-2022-22757 با شدت متوسط، سبب می شود که Remote Agent نتواند مانع اتصال وب سایت های محلی شود، Remote Agent به مصرف کنندگان اجازه می دهد تا بوسیله مجموعه ای از دامنه ها بمنظور بررسی وضعیت، کنترل اجرای اسناد درحال اجرا در محتوای وب، تزریق اسکریپت های دلخواه به اسناد، شبیه سازی تعامل کاربر برای اهداف خودکار، مشترک شدن در بروزرسانی های مرورگر مانند گزارش های شبکه و کنسول و غیره با فایرفاکس ارتباط برقرار کنند.
لطمه پذیری CVE-2022-22758 با شدت متوسط، سبب می شود tel: linkها بتوانند کدهای USSD را برای شماره گیرِ فایرفاکسِ اندروید ارسال نمایند. این نقص فقط فایرفاکس نسخه اندروید را تحت تاثیر قرار می دهد و سایر سیستم عامل ها تحت تأثیر قرار نمی گیرند.
لطمه پذیری CVE-2022-22759 با شدت متوسط، سبب اجرای اسکریپت توسط Sandboxed iframeها می شود.
لطمه پذیری CVE-2022-22760 با شدت متوسط، امکان تشخیص پاسخ های Cross-Origin را از بین انواع محتوای اسکریپتی و غیراسکریپتی فراهم می آورد.
لطمه پذیری CVE-2022-22761 با شدت متوسط، سبب می شود که تنظیمات frame-ancestors در دستورالعمل Content Security Policy، برای صفحات افزونه دارِ دارای چهارچوب اجرا نشود.
لطمه پذیری CVE-2022-22763 با شدت متوسط، سبب اجرای اسکریپت در زمان بروز خطای invalid object state می شود.
تمام نسخه های پیش از Firefox 97 و Firefox ESR 91.6 تحت تأثیر لطمه پذیری های مذکور قرار دارند، بدین سبب به کاربران و مدیران سفارش می شود، هر چه سریع تر مرورگر فایرفاکس خودرا به نسخه ی Firefox 97 و یا Firefox ESR 91.6 بروزرسانی کنند.




منبع:

1400/11/23
23:56:08
5.0 / 5
390
تگهای خبر: توسعه , سایت
این مطلب را می پسندید؟
(1)
(0)

تازه ترین مطالب مرتبط
نظرات بینندگان در مورد این مطلب
لطفا شما هم نظر دهید
= ۹ بعلاوه ۴
لباس نو